Home Button  Buy Button 

Topic:   FANUC O-M cnc not recieving

By: GuestPosted on: Jun 20 2014 at 05:59:22 PM
The settings in easy DNC 4.0 got erased. Now when i send programs to the Fanuc o-m controler it gives me an alarm sequence number not specified. Trying to run a program that was just ran oin machine so program is good. I re set-up dnc to what i could find on settings

By: GuestPosted on: Jun 20 2014 at 10:14:55 PM
Not much you can do wrong with a fanuc.

Are you loading the program into cnc memory or are you drip feeding?

Is there an alarm number?

By: GuestPosted on: Jun 20 2014 at 11:13:19 PM
Drip feeding. Getting alarm 128 p/s alarm (the sequence number specified in branch command was not 0 to 99999. or, it can not be searched). I think I set this machine up one other time, but cant seem to get it working this time.
Data bit: 7 Xon/Xoff
Stop bit: 1
Parity: Even
Block end: CRLF
Block delay: 150
Force CR/LF: on

By: GuestPosted on: Jun 21 2014 at 05:58:19 PM
Does it manage to do any of the program? Or does it crash on the first line?

By: MattPosted on: Jun 21 2014 at 06:02:50 PM
Fanuc alarm 128 could be a goto or jump to a sub routine (or line?) that doesn't exist.

As the previous "guest" said. Does the machine manage to work at least part way through the program before throwing the alarm? Can you see what line it occured on? Is it Jump or call or a canned cycle or macro?

By: GuestPosted on: Jun 23 2014 at 12:15:45 PM
It alarms as soon as the program is sent. its not a canned cycle or a call. i have tried a few dif programs that i know are good programs.

By: GuestPosted on: Jun 23 2014 at 03:52:28 PM
Figured out the problem. The baud rate wasnt set on the cnc the same as the others. Thanks for the help.

By: GuestPosted on: Nov 27 2014 at 08:26:32 PM
has anyone had a ps oo4 alarm?

By: GuestPosted on: Nov 28 2014 at 10:08:54 PM
PS 004 is usually a simple syntax error. Take a good look at the line following the one where the error occured.

By: GuestPosted on: Oct 22 2015 at 04:32:00 PM
errore 87 e 128 ?

By: GuestPosted on: Oct 24 2015 at 09:03:16 AM
87 is flow control. Make sure the DNC has flow control enabled (xonxoff). If that doesn't help then also increase the DNC Block Delay.
Also disable FIFO in Windows.. Control Panel/System/Device Manager/Ports.

I think 128 would occur if there was a call or jump to a sub program that didn't exist in CNC memory. Unfortunately it also occurs if there's data errors because when the data is junk the cnc could think its being told to do something or jump somewhere that doesnt exist.

So, fix the flow control problem and the 128 might go away as well.

By: GuestPosted on: Dec 25 2015 at 10:18:46 AM
Frequent 004 alarm observed. However ,machine works after reset.

By: GuestPosted on: Dec 25 2015 at 10:18:48 AM
Frequent 004 alarm observed. However ,machine works after reset.

By: GuestPosted on: Jun 23 2016 at 08:31:20 PM
001 128

By: Bill WillisPosted on: Sep 14 2016 at 06:42:25 PM
Cannot upload to fanuc control or Hitichi seiki lathe. Download to tablet works fine. settings should be same for up load and down load. I know comm cable is good , because if I change any settings the machine will get and p/s 86 alarm when trying to upload. I put the setting back to same as download and program on remo will show send and green line goes across bottom but no program in machine. What am I doing wrong HELP AAHHHH TY.

By: SupportPosted on: Sep 14 2016 at 08:21:15 PM
You said that you know the comm cable is good. But how do you know?

Upload and downloading use different wires within the cable so it is possible for the cable to work in one direction only. Are you able to open the connectors to make sure there's no loose solder joint on pins 2 and 3 at either end.

That 86 alarm is strange. That's a different problem not related to the software settings so it's strange how the software settings can cause the 86 alarm. I wonder if that's a red herring.

If you look at the cable diagram

See the short connection between pins 6, 8 and 20. If those connections were missing, or if the cable was disconnected (or connected to the wrong port on the CNC) then you would get the 86 alarm.

I mentioned wrong port on the CNC because although you might only have one port on the outside of the machine body. Internally there may be more than one and it may be possible to setup the send and receive to use different ports.

By: GuestPosted on: Oct 26 2017 at 05:55:37 PM
error 008

By: GuestPosted on: Oct 26 2017 at 06:37:08 PM
Error 008 ? Is that P/S 008 Does that happen at the end of the program? Does the program end with an M02 or M30 ?

By: GuestPosted on: Feb 21 2018 at 07:07:29 PM
I use code shark. It can scan thru to a line number with a m99 p333 at beginning.
I had an alarm repeatedly later after n333.
I think the control saw a n33 later in the code and jammed up the works.
Out of numerical order?...
Worked now.

By: AdamPosted on: Jul 16 2019 at 02:05:28 PM
Can you give me your settings for Code shark? I'm trying to send a program to the CNC but my computer does not recognize the CNC. Thanks!

By: GuestPosted on: May 7 2022 at 09:47:34 PM
hello i have fanuc om controller i am getting ps alrm 000
please help me

By: GuestPosted on: May 14 2022 at 09:53:40 AM
PS 000 is not a data input/output error. If I'm not mistaken it's the control machine telling you to power off. It's needs to reboot.

But I did hear somebody say once that it can occur when the memory is full and deleting something can help

This forum is for the EasyDNC software so not really the place for the this kind of question. Suggest trying CNC Z0NE dot com

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- FANUC O-M cnc not recieving

Enter the numbers.

Your name here is optional