Home Button  Buy Button 

Topic:   Mazak Mazatrol M Plus

By: GuestPosted on: Aug 2 2006 at 03:20:13 PM
i am trying to drip feed a program with the m plus control. i made a cable per one of your prints. i can start the program on the machine, but i can only get about afew pages of code and it stops. i can a tape error on the machine. any recomendations?

By: SupportPosted on: Aug 2 2006 at 05:44:49 PM
There`s a number of things that can go wrong with Mazak M Plus For example the number of databits would normally be set to 8 even though the DNC software would be set to 7 (Confuses quite a few people)
(Number of Databits in the control is parameter G5 set this to = 3)

but the fact that you say you`re feeding a few pages before any error occurs indicates that it`s not a data format error but more like an overflow/flow control error.

What setting do you have for flow control/handshaking ? (Para G10 in the control)

Can you say what the tape error is? I mean is there a more detailed description of the tape error?

Are you using a proper COM port or is it a USB adapter?

By: GuestPosted on: Aug 2 2006 at 06:45:26 PM
i have g10 set to 1 (rts/cts) but i tried all settings. the alarm is 887 tape i/o error (an error has occured in the tape reader). so the g5 parameter should be set to 3?

By: GuestPosted on: Aug 2 2006 at 06:55:07 PM
i am using a comm port with a 9 to 25 cable.

By: SupportPosted on: Aug 2 2006 at 08:51:41 PM
If you don`t have G5 set to 3 then it could cause a problem although I suspect it would fail straight away. The fact that you can send a few pages of data before the error suggests that it isn`t caused by that setting

I`d suggest setting as follows.

G1 is the baud rate. 1 = 9600 (will it go slower? Better if you can go qite slow for the sake of debugging the problem.
G2 = 2 (number of stop bits)
G3 = 0 (Parity = Even)
G5 = 3 Data bits = 8
G10 = 1 (rts/cts)

And make sure easyDnc is setup to 7dbits, even parity, 2 stop bits.

As I mentioned earlier, mazak seem a bit confused about their number of databits. Their 8 is the same as everyone elses 7 (They include the parity bit as a data bit for some reason so set the mazak to 8 databits and the DNC computer to 7)

you can only use rts/cts if the cable is configured correctly like this:-

2 - 2
3 - 3
4 - 6
5 - 7
6 - 20
7 - 5
8 - 4

and at the CNC end of the cable make a small short between pins 8 and 20

You can email me directly if you want for a quicker response. I`ll then come back later and post the result here in case any one else has a similar problem.

By: Guest,Posted on: Apr 11 2010 at 04:20:41 PM
Make sure your computer is not going into sleep mode or screen saver mode, you may want to change the time between inactivity. When you drip feed and the computer goes asleep, it stops the drip feed.

By: ALFIN,Posted on: Mar 13 2011 at 03:42:42 PM

By: Markus,Posted on: Mar 13 2011 at 10:03:21 PM
Not quite sure. it would usually happen if you were using DPRINT commands to output data via the rs232 port to a text file. For example if the file could not be created or the file was larger than remaining disk space/memory.

Mazak aren't too helpful about publishing their alarm codes but I get the impression that 887 is a generic alarm that the machine throws for all manner of errors.

Check the bit settings. Mazak set to 8 bit but set easydnc to 7.

Mazak has EIA or ISO. Set to ISO

If possible disable VParity and HParity checking.

Make sure the cable is wired correctly.

By: ALFIN,Posted on: Mar 14 2011 at 03:53:51 AM

By: mazport 1Posted on: Dec 5 2011 at 01:52:31 AM
did you find a solution, I have same problem it will work fine if I put 1ms delay after each character

By: mazport1Posted on: Dec 5 2011 at 01:54:15 AM
Oh forgot to mention 887 error means comms error check parameter setting

By: GuestPosted on: Dec 12 2011 at 12:00:22 AM
USE com port 1 or 2. Com port 3 and 4 will be interruped

By: MickPosted on: Jan 20 2012 at 06:56:04 PM
Check the comm port FIFO buffer settings on your drip feeding computer. Keep reducing the "transmit" settings until the cnc doesn't stop running. You need to re-boot the computer every time you change the setting. I run the setting at 3. Receive setting can be 14

By: udayPosted on: Jun 12 2012 at 12:23:34 PM
hi i am using cimco to transfer data to mazak avj mill m32 sending small program to machine is not a problem when i try drip feeding in tape mode it takes upto 28 lines stops with 887 TAPE I/O ERROR

hi mick can u pls explain more about fifo buffer setting

By: Mike2Posted on: Jun 14 2012 at 09:14:58 AM
at the top of the page is the search box. Enter FIFO into that box and you'll find a page explaining how to adjust fifo.

I would suggest completely disabling both transmit and receive FIFO.

I would also remind you that this isn't the CIMCO support forum. Good of the easyDnc team to allow CIMCO support questions to stay here.

By: GuestPosted on: Nov 2 2014 at 11:20:41 AM
Hey guys I have just brought a machine with a mazatorl m plus and wondering what is a good post processor for windows 7 and I am running solid works ??


By: Guest JoefPosted on: Oct 12 2015 at 07:29:27 PM
Im getting an error code (684) point cutting pattern error on a Mazak ajv-25/404n machine. not sure what this means ?

By: GuestPosted on: Oct 13 2015 at 04:57:01 PM
error code (684) point cutting pattern error on a Mazak?

According to the alarm list:-

"The point-machining shape definition data is not appropriate."

By: PaataPosted on: Mar 13 2017 at 08:16:08 PM
my cnc mashing mazak vtc-41 problem setingi programs Can help?
Best Regards


By: paaataPosted on: Oct 21 2017 at 04:22:16 AM
Thanks for your helping.
we start mazak vtc-41,Error 070 m02 /30/99!
everithi is ok but we can't start program. if you can help,
which G code (post processor) we must to use?
or when we can find a manual instructions.
Best Regards
Paata Museridze

By: paaataPosted on: Oct 21 2017 at 04:22:17 AM
Thanks for your helping.
we start mazak vtc-41,Error 070 m02 /30/99!
everithi is ok but we can't start program. if you can help,
which G code (post processor) we must to use?
or when we can find a manual instructions.
Best Regards
Paata Museridze

By: IuriiPosted on: Oct 29 2017 at 10:06:05 AM
Good morning. Dear Sir.
I need help.
I use milling machine VTC-20B with Mazatrol M-plus. I have your program RemoDNC 5.0. My laptop has Windows 10. Milling machine is connecting with laptop: 25 pin-9pin-usb.
When i receive program to laptop from CNC, on monitor of laptop I see next text:
" ??00000555??????????G5??".
On machine CNC program has next view:
555 (number program)
When I send to CNC I am clicking "Send" button. Window "Progress" reaches 100%.
On monitor the machine appears error "SET NEW PAPER".
Help me with it problem.

Best regards,
Iurii Legkobyt
Dnipro, Ukraine.

By: Clay GarlandPosted on: Feb 27 2021 at 06:19:44 PM
Im doing the programs out of the mazatrol m plus training manual and im getting the "691 mount (valley) shape error" I've looked in the parameters book but the solution i found isn't very clear, can someone help?

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- Mazak Mazatrol M Plus

Enter the numbers.

Your name here is optional